NCR Voyix Payments Gateway - Incident Identified - NCR Voyix Payments – Incident details

Incident Identified - NCR Voyix Payments

Resolved
Operational
Started about 1 year agoLasted about 4 hours
Updates
  • Resolved
    Resolved

    NCR Voyix Incident Tracking: INC1898530

    The issue has been resolved. AMEX will fund based on defined schedules from data receipt. Deposits are expected to be delayed 3-5 days for transactions 2/23 - 2/26.

  • Monitoring
    Monitoring

    NCR Voyix Incident Tracking: INC1898530

    All outstanding files have been submitted for processing and subsequent funding by AMEX. Teams are following up with AMEX to confirm processing status.

  • Identified
    Identified

    NCR Voyix Payments has identified following issue(s) impacting American Express funding

    • Impact - A subset of NCR Payments Processing customers have funding delays on American Express transactions from Feb 22 - Present

    • Action - No actions are required on the customer end, at this time. Teams are actively addressing the processing of these settlement files.

    Incident Tracking: INC1898530 - American Express Funds Delayed for a Subset of NPP Merchants